Freitag, 17. November 2017

Bug0024 – Komponente verliert temporär Verbindung zur Homebase

Bug0024 – Komponente verliert temporär Verbindung zur Homebase

Effekt: Sporadisch reagieren Komponenten nicht auf Befehle (Telekom Smarthome App: Fernbedienung oder Situationen)

Laut meinen Notizen (die ich vor meinem potentiellen Abschied von der Qivicon teils noch aufräume) gibt es dieses Phänomen bzw. diesen Fehler seit über einem Jahr. Er ist im Herbst 2015 erstmals aufgetreten. Tritt regelmäßig in unterschiedlicher Abständen und Häufigkeit auf (min. 1x pro Quartal, teils bis 5x im Monat).

  • Telekom Smarthome App
    • in der Übersicht wird die Komponente mit „nicht sichtbar“ mit einem roten Ausrufezeichen „!“ aufgelistet
    • in der „Fernbedienung“ wird „nicht erreichbar“ mit einem klein Icon angezeigt
  • Komponenten-Typ
    • Batterie betriebene Komponenten
    • durch das Stromnetz versorgte Komponenten
      • durch ein manuelles Schalten mittels der App-„Fernbedienung“ wird die Verbindung wieder hergestellt
      • danach funktioniert die Komponente wieder manuell bzw. indirekt via Situation
  • Phänomen tritt auch mit 1 Meter entfernten Komponenten auf, für die funk-technisch „Sichtverbindung“ besteht

Beiträge zu diesem Fehler:

Intern

1 Kommentar

  1. Boeffi

    Es gibt inzwischen mehrere Beiträge in der Qivicon-Community, die direkt und indirekte vom selben Fehler berichten. Dazu von mir eine erneute Fehler-Ergänzung unter

    https://community.qivicon.de/feedbacks/schaltaktor-temporar-nicht-erreichbar?page=1#anchor_answer_184354

    Update:
    der Fehler „nicht erreichbar“ trat in den beiden vergangenen Tagen erneut mehrfach auf.

    Er konnte jeweils „geheilt“ werden, wenn
    – entweder der Aktor per Fernbedienung direkt
    – oder per manuell geschalteter Situation indirekt
    geschaltet wurde.

    Zusätzlich ist mir durch lesen der Beiträge von legro aufgefallen, dass der Fehler derzeit immer nur dann auftritt, wenn die Anlage von „ABWESEND“ auf „ZU HAUSE“ umgeschaltet wird (und damit das Alarmsystem nebst automatischen Situationen de-aktiviert wird).

    Wie von mir schon an anderer Stelle mit meinem Hintergrund als Java/OSGi-Entwickler vermutet, könnte es an einem System-Engpass im Rahmen der Event- oder/und Interrupt-Verarbeitung liegen, durch den die Qivicon bei „Überlast“ einfach nicht mitbekommt, dass dort „noch mehr zu tun“ ist. Die Überlast-Vermutung hatte auch legro schon in diversen Beiträgen vermutet. Das genutzte Java/OSGi ist halt kein Real-time Operation System. Dementsprechend müssen auf Entwicklerseite entsprechende Vorkehrungen getroffen werden und diesbezüglich Know-How aufgebaut werden.

    CU
    Boeffi

Kommentar absenden

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.